通达信股票公式之一----突破形态

贡献者: paulshee

这个公式是通达信股票行情软件可以用的突破形态的主图公式。

1打开通达信股票软件,菜单选择“功能”-->"公式系统"-->"公式管理器"。

2在公式管理器页面中,选择上面标签中的“用户”标签,点击旁边的“新建”按钮。

3在“指标公式编辑器”界面中,按照下图,填写公式名称、参数PD、P1、P2。并将下面的公式内容copy 到编辑器下面的内容里面。最后点击确定即可。最终显示的主图公式如下所示。{MA(C,5);}MA(C,P1),LINETHICK2,COLORBLUE;MA(C,P2),LINETHICK3,COLORMAGENTA;CD: CURRBARSCOUNT,NODRAW;H0:= C=HHV(C,PD) ,NODRAW;PDD:=IF(CD<PD,CD,PD);GD:= IF(CD<=15,0,H0 AND REFX(EVERY(C<REF(C,BARSLAST(H0)),7),7)),NODRAW;GD1_D:= BARSLAST(GD),NODRAW;GD2_D:= REF(GD1_D,GD1_D+1)+GD1_D+1,NODRAW;GD3_D:= REF(GD1_D,GD2_D+1)+GD2_D+1,NODRAW;GD4_D:= REF(GD1_D,GD3_D+1)+GD3_D+1,NODRAW;GD5_D:= REF(GD1_D,GD4_D+1)+GD4_D+1,NODRAW;GD6_D:= REF(GD1_D,GD5_D+1)+GD5_D+1,NODRAW;GD7_D:= REF(GD1_D,GD6_D+1)+GD6_D+1,NODRAW;GD1_C:= REF(C,GD1_D),NODRAW;GD2_C:= REF(C,GD2_D),NODRAW;GD3_C:= REF(C,GD3_D),NODRAW;GD4_C:= REF(C,GD4_D),NODRAW;GD5_C:= REF(C,GD5_D),NODRAW;GD6_C:= REF(C,GD6_D),NODRAW;GD7_C:= REF(C,GD7_D),NODRAW;SUMV:= REF(V,2)+REF(V,1)+V+REFX(V,1)+REFX(V,2),NODRAW;GD1_V:= REF(SUMV,GD1_D),NODRAW;GD2_V:= REF(SUMV,GD2_D),NODRAW;GD3_V:= REF(SUMV,GD3_D),NODRAW;GD4_V:= REF(SUMV,GD4_D),NODRAW;GD5_V:= REF(SUMV,GD5_D),NODRAW;GD6_V:= REF(SUMV,GD6_D),NODRAW;GD7_V:= REF(SUMV,GD7_D),NODRAW;GD_C_MAX: MAX(GD1_C,MAX(GD2_C,MAX(GD3_C,MAX(GD4_C,MAX(GD5_C,MAX(GD6_C,GD7_C)))))),NODRAW;GD_V_MAX:= MAX(GD1_V,MAX(GD2_V,MAX(GD3_V,MAX(GD4_V,MAX(GD5_V,MAX(GD6_V,GD7_V)))))),NODRAW;GD_C_MAX_D: IF(GD_C_MAX=GD1_C,GD1_D,IF(GD_C_MAX=GD2_C,GD2_D,IF(GD_C_MAX=GD3_C,GD3_D,IF(GD_C_MAX=GD4_C,GD4_D,IF(GD_C_MAX=GD5_C,GD5_D,IF(GD_C_MAX=GD6_C,GD6_D,GD7_D)))))),NODRAW;TP:= REF(C,1)< REF(GD_C_MAX,1) AND C>REF(GD_C_MAX,1),NODRAW;DRAWTEXT(TP,GD_C_MAX,'T'),COLORBLUE;{DRAWNUMBER(GD,C*1.02,C),COLORRED;}DRAWNUMBER(MOD(CD,23)=0 AND C<GD_C_MAX AND CD<300, GD_C_MAX,GD_C_MAX),COLORBLUE;GD_C_MAX_REF:=REF(GD_C_MAX,BARSLAST(GD_C_MAX<>REF(GD_C_MAX,1))+1),NODRAW;GD_C_MAX1:=IF(GD_C_MAX<GD_C_MAX_REF,GD_C_MAX_REF,GD_C_MAX);GD_C_MAX1_D:=GD_C_MAX_D;GD_C_MAX2_D:= REF(GD_C_MAX1_D,GD_C_MAX1_D+1) + GD_C_MAX1_D + 1,NODRAW;GD_C_MAX2:= REF(GD_C_MAX,GD_C_MAX2_D),NODRAW;GD_C_MAX_LONG:= IF(GD_C_MAX_D>30,GD_C_MAX,GD_C_MAX1),NODRAW;{STICKLINE(GD_C_MAX1=REF(GD_C_MAX1,1),GD_C_MAX1,GD_C_MAX1,2,1),COLORBLUE;STICKLINE(CD<30 AND C>GD_C_MAX2 AND REF(CD,GD_C_MAX1_D)=CD+GD_C_MAX1_D,GD_C_MAX2,GD_C_MAX2,3,1),COLORBLUE;}STICKLINE(L<GD_C_MAX1 AND CD<200 ,GD_C_MAX1,GD_C_MAX1,3,1),COLORMAGENTA;STICKLINE(L<GD_C_MAX AND CD<200 ,GD_C_MAX,GD_C_MAX,3,1),COLORMAGENTA;STICKLINE(L>GD_C_MAX AND CD<20 ,GD_C_MAX,GD_C_MAX,3,1),COLORMAGENTA;DRAWNUMBER(MOD(CD,23)=0 AND C<GD_C_MAX AND CD<300, GD_C_MAX1,GD_C_MAX1),COLORBLUE;DRAWNUMBER(MOD(CD,10)=0 AND CD<20, GD_C_MAX1,GD_C_MAX1),COLORBLUE;DRAWNUMBER(TP AND REF(GD_C_MAX_D,1)>20,H*1.01,REF(GD_C_MAX_D,1)),COLORBLUE;

4公式使用说明。公司参数PD默认为30 ,表示突破点是30个周期内的最高点,该最高点被突破,对日线主图来说是中线的突破。你可以修改PD为10,表示突破点是10个周期内的最高点,该最高点被突破,对日线主图来说是短线的突破。

有疑问请留言

1 2 3 4 5