通达信软件怎么自编公式?:[1]

贡献者: 快乐吧415

软件自带很多技术指标和选股公式,但有的朋友想根据自己的炒股经验来编写自己的公式,下面给大家分享我的经验。

1打开炒股软件

2点击左上角的“功能”>"公式系统">"公式管理器"

3如果要自编技术指标公式,就按"技术指标公式">"大趋势"的“+”。

4如果要自编选股公式,就按"条件选股公式">"指标条件选股"的“+”

5下面就逃顶技术指标公式来讲解一下,先按"技术指标公式">"大趋势"的“+”,再按右上角的新建按钮。

6在公式名称写入"逃顶",在下面写入自己编写的公式。VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;VAR2:=SMA(VAR1,9,1)+100;VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;VAR4:=SMA(VAR3,3,1);VAR5:=SMA(VAR4,3,1)+100;VAR6:=VAR5-VAR2;S: IF(VAR6>100,VAR6-100,0);

7然后按右边的"测试公式",下面会显示"测试通过!",表示自编公式已经编好,最后按右上角的"确定"就OK了。

如果显示"错误句:",表示公式有错误,需要修改后再测试,直到通过为止。

1 2 3 4 5